Вложенные функции

Аргументы функций могут быть выражениями, которые содержат функции, например: =ЕСЛИ( СРЗНАЧ(B2:B6)>100; СУММ(B2:B6) ; МАКС(B2:B6))

Функции, входящие в аргументы других функций называются вложенными функциями. В формулах можно использовать до семи уровней вложения функций. Когда функция Б является аргументом функции А, то функция Б считается функцией второго уровня вложенности. Например, функции СРЗНАЧ и СУММ считаются функциями второго уровня, потому что обе являются аргументами функции ЕСЛИ. Функция, вложенная в качестве аргумента в функцию СРЗНАЧ, будет функцией третьего уровня и так далее.

Для ввода вложенной функции нельзя использовать кнопку fx . Надо воспользоваться списком функций в строке формул.

Например, чтобы сделать функцию СРЗНАЧ аргументом функции ЕСЛИ, щелкните поле логическое_выражение в окне функции ЕСЛИ, затем стрелку вниз в списке функций в строке формул, в раскрывшемся списке выберите СРЗНАЧ.

Заполнив аргументы функции СРЗНАЧ, щелкните функцию ЕСЛИ в отображении вводимой формулы в строке формул — вы вернетесь в окно функции ЕСЛИ (нельзя нажимать кнопку OК для функции СРЗНАЧ). Завершите ввод условия, набрав “>100” (СРЗНАЧ(B2:B6)>100).

Чтобы сделать функцию СУММ вторым аргументом функции ЕСЛИ, щелкните поле значение_если_истина в окне функции ЕСЛИ, затем стрелку вниз в списке функций в строке формул, в раскрывшемся списке выберите СУММ.

Заполнив аргументы функции СУММ, щелкните функцию ЕСЛИ в отображении формулы в строке формул. Появится окно мастера функций для функции ЕСЛИ.

Щелкните поле значение_если_ложь и выберите из списка в строке формул функцию МАКС.

Чтобы переключаться между окнами уже введенных функций в режиме ввода, щелкните мышкой на имени нужной функции в отображении формулы в строке формул. Например, чтобы сменить диапазон функции СРЗНАЧ, щелкните имя этой функции в строке формул.

Замечание.

Только в конце ввода всей формулы (после ввода аргументов функции МАКС) можно нажать кнопку OК.


9139044165845268.html
9139070035233807.html

9139044165845268.html
9139070035233807.html
    PR.RU™